Picard 0.5.0 released!

After too many months of tinkering the latest stable release of Picard has been released:

Big thanks goes out to Lukas Lalinsky for fixing many bugs and creating the Windows installer. Also, many thanks to everyone who helped work on the Norwegian, German, French, Russian and Slovak translations!

Technorati Tags: , ,

Changes from 0.5.0-pre2:

These bugs have been fixed:

  • 1043636 selecting more tracks in the right pane
  • 1042891 tagger stops loading album info
  • 1238616 loading indefinately on “non-album tracks”
  • 1310462 Error in GetResultData1
  • 1306106 Picard adding junk ASCII to fields, plus clearing tags
  • 1354607 drag item: “Albums” => outside: item frozen in New files
  • 1349235 Filenames with DOT in the end!
  • 1335314 Problem with directory names that contain periods
  • 1329043 Serious FS issue. Picard creates dirs with invalid names!
  • 1051940 Picard: Unicode support under Windows is broken still
  • 1236964 “Clear existing tags before writing” appears to be ignored
  • 1251813 full album time is readded with ‘Reload album from server’

For more info on these bugs take a look at our bug tracker, category picard.

Other improvements:

  • Internationalization (gettext) + Norwegian, German, French, Russian and Slovak translations.
  • Multiple-select in the album panel.

12 thoughts on “Picard 0.5.0 released!

  1. dave

    I’m getting the following error, on Ubuntu Breezy, when running tagger.py though libmb and libtp install without giving errors:

    ImportError: No module named tunepimp

    Any hints? It’s probably something simple but I’m out of my depth here.

  2. dave

    OK it’s me again. The actual program seems fine but it’s acting like the internet doesn’t exist, probably because I’m behind a proxy.

    Does Picard pick up proxy settings from somewhere?

  3. lukas

    Btw, if anyone else is interested in translating Picard, please send me e-mail or come to the IRC channel #musicbrainz on irc.freenode.net

  4. for4saken

    After I tagged some files with Picard, WMP10 stops recognizing them [the tags] and doesn’t play the files anymore. It gives error:C00D0BB8, apparently about compacted ID3 header.

    And now, I read the bug fixes again and realized that Unicode still doesn’t work. Back the config to Latin1 and it’s working just fine. 🙂

    Anyway, how could I help with a portuguese translation?

  5. Mayhem & Chaos

    Replies to two comments above:

    Dave: sorry we haven’t implemented the proxy panel yet. Perhaps I can get that done over the weekend.

    for4saken: Check to see which version of id3 tags you are writing. Switch to the other one and try again.

  6. Ben

    The Picard taggger is the next generation tagger that will soon completely replace the old windows only (etc)
    How exactly will I tag all those tagless mp3s that I always seem to find, if Picard doesn’t use acoustic fingerprints?

  7. Guille

    Yep, Re: Mayhem & Chaos’ comment, I understand the reason to move from the old tagger to Picard, but why wasn’t it possible to leave the acoustic fingerprint as a last resource, when every other meaningful detail in the ID3 or the filename is missing?

  8. BGreeNZ

    Re acoustic fingerprints, how does Picard deal with files that are mistagged? I seem to find those quite frequently on file sharing networks, and is the main reason why I started using the MusicBrainz Tagger in the first place. If the goal of Picard is to reduce the load on the TRM server, then why not keep acoustic fingerprinting, but fall back on it only if the metainfo in the filename / tags is suspicious or missing?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s