Running mb_server on Apache2

A number of people have expressed interest in running mb_server on Apache 2, rather than Apache 1 as mb_server currently requires. Our current roadmap calls for the next mb_server release to stay on Apache 1 and the following Template Toolkit branch to move to Apache2. There will be a lot of changes to the codebase going to TT, so it makes sense to make the switch to Apache 2 at that time since we have to test everything anyway.

LAADHARI Saber has created a “quick and dirty” port of mb_server to apache2. The patch uses the Apache2 compat module and still has some problems with Auth.pm in the Web Service.

Given our roadmap, we’re not going to accept this patch into our codebase, but I wanted to offer up this patch to anyone who wanted to use it.

Thanks LAADHARI Saber!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s