Web service user-agent string blocking reminder

I would like to remind Web Service users that on 16 November we’re going to block generic User-Agent strings from accessing our web service. Earlier we said:

The User-Agent string needs to identify the application and the version of the application that is making the request; having a generic User-Agent string like “Java/1.6.0_24″ or “PHP/5.3.4″ does not allow us to properly identify the application making the requests.

IMPORTANT: 6 Months after we release NGS (Nov 16th) we’re going to start blocking common generic User-Agents strings, so please make sure that you send us a proper User-Agent header as part of your request.

You have been warned. 🙂

9 thoughts on “Web service user-agent string blocking reminder

  1. patate12

    Are the userjs concerned by this block ? I guess current user agents might be something like Opera/9.80 (Windows NT 5.1; U; en) Presto/2.9.168 Version/11.52 (depending on the browser).
    Are these allowed ?

  2. Paul C. Bryan

    I’m looking at libwebservice-musicbrainz-perl, (Query.pm:130) which sets the User-Agent header to “WebService::MusicBrainz/0.93”. There are no hooks for applications to modify the User-Agent header in this library. Will this library be at risk?

  3. mayhem

    Paul: No we’re not going to block those. First we need to add support for setting user agent strings in all of our client libs. Then we’ll need to allow the generic strings like this one for at least a year before we start blocking those. I’m working on a comprehensive plan for all of this now.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s